i4SCADA Knowledge Base

i4SCADA Studio Overview

Abstract

Were you wondering how the i4SCADA Studio looks like? Check out this article for a quick view through the application UI, sprinkled with screenshots and tables.

i4SCADA Studio is the project configuration tool included in the i4SCADA software suite. Using the Studio, the user can link the i4SCADA system to the control units at field level and define the operating conditions of the controlled facilities.

Capture445.jpg

Studio - Signals area - Main view

The configurations set up in Studio are stored in the database. The i4SCADA Server uses the configurations to manage the communication with the control units at field level.

Using the Studio, the user can perform the following specific tasks:

  • set up the servers

  • connect to OPC servers

  • configure signals

  • define and configure alarms

  • set up symbolic texts and translations

  • manage users (using the integrated web application User Manager)

  • perform advanced setup

The User Interface

The user interface of i4SCADA Studio  of following sections, is briefly explained below:

The Login Dialog

The i4SCADA Studio Login dialog allows the user to access the desired database using Studio. The user is able to access the correct project database from any location (local or remote database servers) and using the preferred language.

Capture1645.jpg

Studio Login

The i4SCADA Studio Login dialog provides a faster way to log in to the DemoProject database by using the Open demo configuration button. No other options or credentials must be provided when using the Open demo configuration button.

i4SCADA Studio Login options

Description

Database server

Allows the user to select the database server on which the project database is stored. The server can be local or remote.

Authentication

Allows you to either use SQL Server Authentication or Windows Authentication, depending on your setup.

User ID

The database user name. The default user name is "sa".

Password

The database password. The default password is "webfactory".

Database

Allows the user to select the project database. The User ID and Password for the project database must be entered first.

Language

Allows the user to select the language used in Studio.

Open demo configuration

Automatically opens the DemoProject database in Studio. When using the demo configuration, all the above options will be disregarded.

Login

Logs in with the provided options and credentials.

Cancel

Closes the i4SCADA Studio Login window.

License

Displays the license details.

The Main Menu

The Studio main menu provides the user with the options to create a new project, open an existing project, backup or restore projects but also change the project's password, add new servers or browse the network.

Note

The Edit menu is context-sensitive. It will display the options depending on the selected items. The same menu can be opened by right-clicking on the selected items.

Capture1649.jpg

Project menu

Capture1433.jpg

Edit menu

Capture1444.jpg

Help menu

The following tables describe the options provided in the main menu of i4SCADA Studio:

Project name options 

Description

Create Project

Opens the Create Project dialog which allows the user to create a new project.

  • Database - The name of the new database.

  • Database path - The path where the database will be stored on the hard drive.

  • New button - Creates the new database.

  • Cancel button - Cancels the Create Project dialog. No changes will be applied.

Open Project

Opens the Open Project dialog that allows the user to open an existing project. The following details must be provided:

  • Database - Select the desired database to open.

  • Open button- Opens the selected database.

  • Cancel button - Closes the Open Project dialog.

Restore Project

Opens the Restore Project dialog that allows the user to restore a project from a backup file to a new database.

  • Backup file - Select the backup file from the hard drive.

  • Database path - The path of the database where the project will be restored.

  • Database name - The name of the database where the project will be restored.

  • Restore button - Restores the project.

  • Cancel button - Cancels the dialog.

Change Password

Opens the Change Password dialog which allows the user to change the password of the currently logged user.

  • Current Password - The current password of the logged user.

  • New Password - The new password.

  • Confirm New Password - Confirm the new password by re-typing it.

  • OK button - Confirm the change of password.

  • Cancel button - Cancels the dialog.

Backup Project

Opens the Backup Project dialog that allows the user to backup the current project. The following details must be provided:

  • File name - The name of the backup file that will be created.

  • Selected file name - The selected path where the backup file will be saved.

  • OK button - Confirm the backup operation.

  • Cancel button - Cancels the dialog.

Clear Project for Production

Opens the Clear Project for Production dialog which allows the user to remove data and alarm records from the project database.

  • Delete all data before the date - Allows the user to select the date up to which all data will be deleted.

  • Delete all data - If checked, deletes all the project data, ignoring the selected date.

  • OK button - Confirm the delete operation.

  • Cancel Button - Cancels the dialog.

Disconnect Project

Opens the Disconnect Project dialog which allows the user to separate the project database from the database server. A backup file will be created automatically.

  • Database - The database to be separated from the server.

  • Backup file - The path for the backup file that will be automatically created.

  • Disconnect button - Confirms the separation.

  • Cancel button - Cancels the dialog.

Exit

Closes i4SCADA Studio.

Edit menu options

Description

New ...

Allows the user to create a new instance of the selected item: New Server, New Connector, New Group, New Signal, etc.

Delete

Deletes the current selection.

Browse ...

Browse the currently selected item: Browse Network, Browse Server, Browse Connector.

Export Signals

Exports the selected signals. This option is enabled only when signals or signal groups are selected.

Import Signals

Imports the selected signals. This option is enabled only when signals or signal groups are selected.

Refresh

Refreshes the current selected items.

Help menu options

Description

i4SCADA Studio Help

Opens the online help.

Contextual Help

Opens the contextual CHM help file for the Studio application.

About

Shows information about the current version of the software.

The Toolbar

The toolbars provide a fast access to the most important project-related options: project and server options.

Studio_toolbar.jpg

Studio Toolbar

Studio toolbar UI Options

Description

Create a project

Create a new project database.

Open a project

Open an existing project database.

Restore project

Restore project database by means of its backup file.

Backup project

Create backups for the opened project database.

Clear project

Remove data and alarm records from the project database.

Disconnect project

Separate the project database from the database server. A backup file will be created automatically.

Exit

Quit i4SCADA Studio.

Server selection drop-down

Allows the user to select the server to be restarted when using the Take new configuration button. This option is not available in DemoProject due to the number of servers being limited to one.

Take new configuration

Restarts the server selected in the combo-box. The server will load the updated Studio configuration upon restarting. This option is not available in DemoProject due to the number of servers being limited to one.

The Studio's Views

The i4SCADAStudio functionality is divided in five areas.

Capture1472.jpg

Studio functionality areas

  • Signals - the area containing the functionality for managing the Servers, Connectors, Signals, Write Groups and Discrete Values.

  • Alarming - the area containing the functionality for managing the Alarms, Alarm Groups, Alarm Types and Alarm Conditions.

  • Logging - the area containing the functionality for managing the Logs and Log Conditions.

  • Translations - the area containing the functionality for managing the Languages and translations for Signals, Signal Groups, Discrete Values, Extended Alarm Properties, Alarm Groups, Alarm Types, Alarm Texts, Shared Help Texts, vPlant Messages, Logs and all the defined Translation Texts.

  • Settings - the area containing the settings for Database Access, Project, Users and Server.

When opening i4SCADA Studio, the Signals section is displayed by default.

The Studio's Tree Menu

The left side tree menu displays the views of the selected area in a hierarchical manner. When clicking on a menu item, the Studio will display the contents of the selected view in the main panel.

Capture1475.jpg

Area Selection example - Signals area 

The Filter Panel

The Filter panel allows the user to filter the items displayed in the main view using the Columns of the main view and their Values as filter criteria.

Capture1476.jpg

Filter Panel