WEBfactory 2010

Error 1001 while installing WEBfactory 2010 after a previous WFBfactory version

Abstract

Check out this article and learn how to escape the error 1001 while installing WEBfactory 2010 after a previous WEBfactory version.

Description

Windows Installer doesn't uninstall all WEBfactory services while the services are still running, or the Windows Installer doesn't clean up the uninstalled WEBfactory registry entries.

This cause the installation to fail with the error 1001.

This error is thrown when installing WEBfactory on a machine that had WEBfactory installed previously.

Solution

Use the SC command in the command line to stop and delete all WEBfactory service entries.

Optional you can download the Command File and execute it to delete all the WEBfactory service entries. The Command File may opened using a text editor and edited manually.

Click here to download Remove WF Services command file.

IMPORTANT: Use the command only when Error 1001 is shown. If the command is used before the WEBfactory uninstall routine has been started, the uninstall may fail.

If the above solution doesn't fix the uninstall problem (Error 1001), the user must repair the WEBfactory 2010 installation using the WEBfactory 2010.msi and try the uninstall procedure once again, after the repair procedure has finished.:

  1. Open the WEBfactory 2010.msi file located on the WEBfactory 2010 installation disk or from the downloaded files. The WEBfactory 2010.msi file is located in WEBfactory 2010\WF2010 folder.

  2. At the Change, Repair or remove installation page, select Repair.

    Capture1153.jpg
  3. Confirm the next page by selecting the Repair button. The repair routine will begin.

  4. After the repair routine is complete, uninstall WEBfactory 2010.