WEBfactory 2010

Modbus Connector Error Codes

Abstract

Check out this article and learn more details about the WEBfactory 2010 Modbus Connector error codes.

Init

Error Code

Details

0

Success.

-999

License check fails (no license)

-1

Already initialized (Init already called)

-2

Registry reading fails

-3

Configuration XML string received in Init method is not correctly formatted on the syntax level or it does not represent valid Modbus connector configuration

-4

Configuration XML string received in Init method does not allow to build list of signals

ActivateSignals

Error Code

Details

0

Success.

-1

Invalid input parameters in ActivateSignals Method call

Individual signal error codes

Error Code

Details

0

Success.

-1

Activation of the signal denied because number of signals that can be activated specified by Modbus connector license was already reached

-2

Unknown signal name - signal is not configured

WriteSignalsAsync

Error Code

Details

0

Success.

-1

Invalid input parameters in WriteSignalsAsync Method call

Individual signal error codes

As returned by WriteSignalsAsync itself

Error Code

Details

0

Success.

-1

Unknown signal name - signal is not configured

Additional individual signal error codes

As returned by OnWriteSignals event signaling completion of the WriteSignalsAsync call

Error Code

Details

-4

Attempt to write to signal which is neither coil nor holding register

-5

Signal value is of incorrect type and cannot be converted

-7

Data type conversion of the value before writing failed

-10

Writing to device itself failed

WriteSignalsSync

Error Code

Details

0

Success.

-1

Invalid input parameters in WriteSignalsAsync Method call

Individual signal error codes

Error Code

Details

0

Success.

-1

Unknown signal name - signal is not configured

-4

Attempt to write to signal which is neither coil nor holding register

-5

Signal value is of incorrect type and cannot be converted

-7

Data type conversion of the value before writing failed

-10

Writing to device itself failed